Back to overview
Downtime
Issues with ESTO API
Mar 10 at 09:55pm EET
Resolved
Mar 10 at 11:29pm EET
Issues are resolved except for the small % of users.
Affected services
Updated
Mar 10 at 11:12pm EET
ESTO Pay is processing with no to minimal issues.
Credit Account Withdrawals are processing with minimal issues
Hire purchase processed with issues
Affected services
Created
Mar 10 at 09:55pm EET
More details coming.
Affected services